GitLab Security Update Patches Critical Vulnerability

11 months ago 56
BOOK THIS SPACE FOR AD
ARTICLE AD

DevOps platform GitLab this week resolved a critical-severity vulnerability impacting both GitLab Community Edition (CE) and Enterprise Edition (EE).

An open source end-to-end software development platform, GitLab helps developers and organizations build, secure, and operate software. The platform has approximately 30 million registered users.

Tracked as CVE-2023-2825 and leading to arbitrary file reads, the newly addressed security defect has the maximum CVSS score of 10.

“An unauthenticated malicious user can use a path traversal vulnerability to read arbitrary files on the server when an attachment exists in a public project nested within at least five groups,” GitLab explains in an advisory.

The web-based Git repository will release details on the bug only next month, after 30 days have passed since the patch was made available.

According to GitLab, the issue was introduced in GitLab CE/EE version 16.0.0 and was resolved on Tuesday with the release of version 16.0.1 of the platform.

The flaw was reported by a researcher named ‘pwnie’ via GitLab’s HackerOne-hosted bug bounty program.

Given the severity of the bug, all GitHub users running version 16.0.0 of GitLab CE or EE are strongly advised to upgrade to the latest version of the platform as soon as possible. The patch has already been deployed on GitLab.com.

GitLab made no mention of this vulnerability being exploited in malicious attacks.

Related: GitLab Patches Critical Remote Code Execution Vulnerability

Related: Critical Account Takeover Vulnerability Patched in GitLab Enterprise Edition

Related: GitLab Patches Critical Account Takeover Vulnerability

Read Entire Article